Cara Install Mikrotik CHR – Mikrotik sering dibutuhkan ketika mengelola jaringan fisik atau virtual. Mikrotik saat ini tersedia dalam versi cloud yang disebut Mikrotik CHR. Sistem operasi ini memungkinkan Anda untuk menginstal Mikrotik CHR di VPS atau server Anda. Pada artikel ini, Anda akan belajar cara menginstal Mikrotik CHR di CentOS 8.

Mikrotik CR

Mikrotik Cloud Hosted Router, atau disingkat Mikrotik CHR, adalah versi RouterOS yang dirancang khusus untuk memungkinkan perangkat komputer berjalan secara virtual di mesin virtual (VM). CHR menggunakan arsitektur x86 64-bit dan dapat digunakan pada sebagian besar hypervisor seperti VMWare, HyperV atau VirtualBox.

CHR Mikrotik sama dengan RouterOS biasa kecuali untuk level lisensi. Tapi jangan khawatir, kita masih bisa menggunakan CHR dengan lisensi gratis, meskipun traffic dengan lisensi gratis akan dibatasi hanya 1 Mbps per antarmuka.

Namun sebelum menginstal CHR di VPS. Pertama kita perlu membuat cloud VPS. Kali ini saya akan menggunakan provider VULTR. Karena Vultr memiliki VPS termurah, yaitu $3,5/bln. Ada juga $2,5/bulan tetapi dalam hal ini tidak didukung ipv4 dan hanya mendukung ipv6.

Jika Anda tidak memiliki akun Vultr, silakan gunakan tautan Daftar Vultr berikut. Dengan mendaftar dengan tautan ini, Anda akan menerima $100 gratis untuk mencoba layanan Vultr.

Membuat instance baru di Vultr

1. Klik Produk lalu tekan Perluas Instance

2. Kemudian pilih Komputasi awan pada Lokasi server Memilih Amerika pilih secara lokal New York (New Jersey) Cara Install Mikrotik CHR

3. Aktif Jenis server Pilih Centos dengan versi 8 x64Cara Install Mikrotik CHR

4. Aktif Ukuran Server pilih salah satu $3.5/bulan

5. Kemudian jangan lupa sertakan hostname dan labelnya. Jika Anda menekan Perluas SekarangCara Install Mikrotik CHR

Baca juga:   Cara Remote Mikrotik dari Luar Jaringan

Proses penerapan akan memakan waktu setidaknya 5-10 menit.

Cara Install Mikrotik CHR (Cloud Host Router)

Begitulah caranya Install Mikrotik CHR untuk VPS dengan sistem operasi CentOS 8.

Langkah-langkah instalasi:

  • Pembaruan server
  • Instal firewall
  • Download Mikrotik CHR
  • Mikrotik CR.
  • Pengujian

Baca juga: Bagaimana Cara Mendapatkan Pulsa Gratis $10 dari Digital Ocean?

Pembaruan server

Pertama pastikan servernya up to date dulu, tujuannya untuk kemasan yang akan digunakan juga diperbarui. Kemudian lakukan server dimulai ulang.

yum update -y 
reboot

Instal firewall

Firewall yang digunakan saat menginstall Mikrotik di CentOS 8 adalah CSF (ConfigServer Security & Firewall). Menginstal CSF Firewall di CentOS 8 sedikit berbeda dengan menginstal OS lain.

cd /usr/src
wget https://download.configserver.com/csf.tgz 
tar -xzf csf.tgz

Instal dan buat direktori iptables

yum install iptables-services -y
touch /etc/sysconfig/iptables
touch /etc/sysconfig/iptables6

Instal CSF

csf csf/
install.sh
perl /usr/local/csf/bin/csftest.pl

Edit csf.conf, lalu ubah jadikan TESTING menjadi 0.

nano /etc/csf/csf.conf

make TESTING=’0’

Setelah itu simpan dan keluar.

Kemudian muat ulang CSF dengan perintah berikut.

csf -r

Download Mikrotik CHR

Install beberapa paket yang diperlukan untuk menginstall Mikrotik CHR di CentOS 8, kemudian download paket Mikrotik CHR dengan opsi Raw Disk Image, disini kami menggunakan versi stabil yaitu v6.48.6.

yum install wget unzip -y
wget https://download.mikrotik.com/routeros/6.48.6/chr-6.48.6.img.zip -O mik-chr.img.zip

Perintah di atas berarti Anda akan mengunduh dengan wget dan menyimpannya sebagai mik-chr-.img.zip. Jika sudah diunduh, unzip atau ekstrak file .zip dan daftarkan.

unzip mik-chr.img.zip
ls 
--output--
chr-6.47.6.img  mik-chr.img.zip

Artinya proses unpacking sudah selesai.

Mikrotik CR.

Mount file chr-xxxx.img ke direktori /mnt menggunakan perintah di bawah ini.

mount -o loop,offset=512 chr-xxxx.img /mnt

Ubah nama “xxxx” dengan file CHR yang Anda miliki. Kemudian cek hasil mount sebelumnya dengan perintah berikut.

ls /mnt
---output---
bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

Setelah itu, jalankan beberapa perintah di CLI untuk mengatur pengalamatan alamat IP pada antarmuka ether1, rute default dan server DNS dari Mikrotik CHR, yang dapat dieksekusi dengan perintah echo. Sejumlah perintah ini kemudian akan disimpan dalam file autorun.scr yang terletak di direktori /mnt/rw/. Perintahnya akan terlihat seperti di bawah ini.

Baca juga:   Kode Redeem FF Maret 2022, Lengkap Cara Klaim!

Cukup salin dan tempel perintah di bawah ini ke terminal.

ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr

Periksa apakah perintah ditulis dalam file autorun.scr atau tidak.

cat /mnt/rw/autorun.scr
/ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 
/ip route add gateway=103.xxx
/ip dns set servers=8.8.8.8,8.8.4.4

Bagian address = 103.xxx nantinya akan sesuai dengan alamat IP di VPS Anda. Mengingat proses pemasangan telah selesai, Anda dapat melepas (unmout) dengan perintah:

echo u > /proc/sysrq-trigger

Kemudian salin semua konten dan file dari gambar CHR ke /dev/vda menggunakan perintah dd (dump disk) seperti yang ditunjukkan di bawah ini.

dd if=chr-6.47.6.img bs=1024 of=/dev/vda
---output---
65536+0 records in
65536+0 records out
67108864 bytes (67 MB, 64 MiB) copied, 4.20313 s, 16.0 MB/s

Atur versi CHR menggunakan file yang Anda unduh sebelumnya menggunakan perintah wget. Kemudian reboot VPS menggunakan perintah reboot.

reboot

Pengujian

Setelah reboot, Anda dapat mengakses Mikrotik CHR dengan memasukkan alamat IP server Anda. untuk nama pengguna: admin dan kata sandi: (kosong).cara instal mikrotik xp

Dengan Mikrotik CHR, Anda dapat melakukan banyak hal, termasuk menghubungkan Mikrotik dari jarak jauh di rumah/kantor dari jaringan eksternal dengan menghubungkan ke VPN, atau jika Anda memiliki Mikrotik di beberapa lokasi, Anda dapat memaksa Mikrotik untuk terhubung satu sama lain.

Selain itu, Anda juga dapat mengakses hotspot dari luar jaringan dan lainnya dari jarak jauh.

Tutorialnya akan saya bahas di artikel selanjutnya.

Baca juga:   Stoner Nasihati Murid Rossi Cara Jadi Juara Dunia MotoGP – runganSport


https://aaer.org